제어판|관리도구|인터넷정보서비스관리자를 선택하면 <그림 1>과 같이 인터넷 정보 서비스 프로그램이 실행된다.
주의) 만약 제어판|관리도구에 IIS(인터넷 정보 서비스)관리자 프로그램이 없으면 제어판|프로그램 및 기능을 실행하여 좌측 ‘Windows 기능 사용/사용 안 함’에서 실행 후 Windows 기능 창에서 인터넷 정보 서비스를 설치한다. 운영체제의 종류에 따라서 인터넷 정보 서비스 관리자가 지원되지 않을수 있으니 이점을 숙지한다.
<그림 1> 인터넷 정보 서비스 프로그램을 실행한 예
웹 서버 설정을 위해서는 <그림 1>과 같은 인터넷 정보 서비스를 실행하여 다음과 같은 순서로 설정을 해야 한다.
웹 사이트 등록 : <그림 1>의 ‘로컬 컴퓨터’를 선택한 후 웹 사이트 추가 등의 작업을 해야 한다. 웹 사이트 이름, IIS 관련 파일의 경로, IP주소, 포트번호등을 설정한다.
기본 문서 : 인터넷 정보 서비스를 이용하여 화면상에 표시하고자 하는 첫 html 페이지(예, SampleStart.htm 등)를 설정한다.
인증 : 인증 기능을 이용하여 웹 클라이언트가 웹 콘텐츠에 대한 액세스 권한을 얻는 데 사용할 수 있는 인증 방법을 구성한다.
<그림2>에서 익명 인증 항목을 사용, 폼 인증 항목을 사용, ASP.NET 가장 항목을 사용 안 함으로 설정한다.
웹 사이트 시작 : 특정한 웹 사이트에서 ‘작업|시작’ 메뉴를 선택하여 웹 사이트를 시작한다.
<그림 2> 인터넷 정보 서비스 프로그램의 인증 설정 예
주의)IIS의 인증부분에서 ASP.NET 가장을 사용으로 설정하게 되면 <그림 3> 또는, <그림 4>과 같이 웹 페이지에서 에러가 발생하게 되므로, 반드시 ASP.NET 가장 항목을 사용하지 않음으로 설정하여야 하며 사용으로 설정시에는 <그림 3>또는 <그림 4>과 같이 오류가 발생한다.
<그림 3> 서버 접속 오류의 예1
<그림 4> 서버 접속 오류의 예2
관련항목)